Announcement

Collapse
No announcement yet.

fps abnormally low?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fps abnormally low?

    Specs:
    GTX 980 Ti
    i7-4790K
    16 GB RAM
    Windows 10 Pro 64-bit
    installed on an SSD

    With vsync off, on average I'm getting between 120-150 fps, which seems low considering how old this game is as well as my specs, yet I've heard of other people achieving 200+. Is this a Windows 10 problem?

    Setting my minimum processor state to 100% does give me like a 10 fps boost, though still not anywhere close to 200. Oddly enough, forcing 8x AA doesn't seem to have an impact on fps. Is my CPU really bottlenecking...?

  • #2
    It does seem a little lower than I would expect. Are you using Shadowplay at all from the GeForce Experience? I remember Shadow mode (called 'Instant Replay' now) used to decrease my frame rate a bit so I keep it on manual on/off mode ('Record').

    For comparison, I'm getting 135-170 fps now on a i5-4670k@4.2GHz + GTX 770, with stage background on using the same Windows 10 version. AA/AF set to high quality in the control panel, but you're right it doesn't affect the frame rate that much. I think I even used to get 180, but I can't remember what I changed lol.

    i7-4790k can get 200 fps (the official client maximum) playing alone (and probably 170 full room) in Windows 7 even without an overclock, but much harder to get close to that in Windows 10.

    Here's Printemps's post for some overclocked i7-6700k numbers, it's a newer generation but still good info.

    Leebyn Greentlover
    FB | Twitch | Tournament log | PM me about anything ^^ | Not currently a CA.

    Comment


    • Fail Whale
      Fail Whale commented
      Editing a comment
      Yeah, I've already checked to make sure Instant Replay was turned off

      Wonder what could be causing this :\

  • #3
    Get a hardware monitoring program like CPU-Z or HWinfo and keep an eye on your CPU clock speeds - see if it dips at all. It shouldn't based on the Power Option plan settings, so it should say the Core speed is 4400MHz.

    See if there are any CPU hogging processes in the background as well - you can check that one through Task Manager.

    Leebyn Greentlover
    FB | Twitch | Tournament log | PM me about anything ^^ | Not currently a CA.

    Comment

    Working...
    X